Skip to main content

 

Documentation & User Guides | FotoWare

Login to FotoWeb is slow when using Active Directory integration

If you experience performance issues when logging on to FotoWeb using Active Directory integration, these points can help you troubleshoot.

Possible reasons

  • The domain controller is slow to respond
  • Requests to a domain controller are timing out, maybe even deliberately for security reasons

How to debug performance issues logging in

Enable additional logging in FotoWeb

  • Open the Operations Center, go to the FotoWeb tab and choose Configuration | Open. FotoWeb Server settings open in a separate tab.
  • Now open the Service Options tab and choose the System Logging node.
  • Set Application Trace Files to Debug, and then click Save in the bottom right hand corner of the screen.

  • Reproduce the problem
  • Locate the log file fotoweb.exe Script Processing.trace in the folder C:\ProgramData\FotoWare\FotoWeb\Operations\Logs
  • In the file, search for all lines containing "Search completed in" and unusually high values (e.g. several seconds)
  • Find the corresponding log message "Ldap search..." to locate the LDAP quety that was slow

Possible solutions

  • If only lookups of groups or domains that are unnecessary for FotoWeb user authentication are slow, then these queries can be added to the LDAP blacklist.
  • Otherwise, this is either an issue with the LDAP server (e.g., load balancing and one or more slow servers) or the network. It has to be resolved by the network administrator.