FotoStation is newer than my product key allows
Overview
What to do if you have upgraded to a newer FotoStation version and receive an error message when starting it.
Problem
FotoStation displays an error message on startup:
"This version of FotoStation is newer than your product key allows!
If you have signed a subscription agreement, you need to activate the license key for the subscription.
Cause
You have installed a new version of FotoStation, but your current product key is invalid.
Solution
If you have a perpetual license , you must use an older version of FotoStation for which your existing license key is valid.
Alternatively, you can contact your local Fotoware partner to purchase a subscription that allows you to run the most recent versions.
If you already have a valid subscription, you can access your license keys on the Licenses page in the Fotoware Customer Portal.
- Go to http://www.fotoware.com/license-center/ and log in using your fotoware.com account information.
- Verify that the agreement has not expired and that the fulfillment status is Accepted. Then, open the Licenses page or go to https://licenses.fotoware.com/licenses to access the latest key to run the latest version of FotoStation.