Contact Us

If you still have questions or prefer to get help directly from an agent, please submit a request.
We’ll get back to you as soon as possible.

Please fill out the contact form below and we will reply as soon as possible.

  1. Fotoware Alto
    • 11.14 Schreckhorn
    • Terminology
    • Solutions
    • User Guide - Deutsch
    • User Guide - English
    • API Changelog
  2. Fotoware Veloz
    • Managing users and groups
    • Configuring archives
    • Configuring workflows
    • Configuring site behavior
    • Navigating and searching to find your assets
    • Working with your assets
    • Editing asset metadata
    • Uploading files
    • Version Control in Fotoware
    • Albums - Creating and sharing collections
    • Placing assets in a CMS
    • Working with the Fotoware Pro interface
    • Using the Fotoware plugins
    • Consent management
    • User guide to FotoWeb for iPad (Legacy)
    • Picture conferencing with FotoWeb Screens (Legacy)
    • What's what in Fotoware
    • GDPR
    • Fotoware Veloz releases
    • Activity Exports
    • Fotoware Example Workflows
  3. Fotostation
    • Getting started with Fotostation
    • Viewing, selecting and sorting files
    • Managing your assets with archives
    • Adding metadata to assets
    • Searching for assets
    • Working with your assets
    • Version Control in Fotostation
    • Automating tasks with Actions
    • Configuring metadata fields and editors
    • Configuring Fotostation
    • Configuring Fotostation for multi-user environments
    • Troubleshooting Fotostation
  4. Fotoware Flow
    • What is Flow?
    • Getting started
    • Flow dictionary
  5. Fotoware On-Premises
    • Getting started
    • Index Manager
    • FotoWeb
    • Color Factory
    • Connect
    • Operations Center Guide
  6. Integrations and APIs
    • The Fotoware API
    • Creating integrations using embeddable widgets
    • Authorizing applications using OAuth
    • Auto-tagging
    • FotoWeb Drag and Drop export
    • Integration using webhooks
    • Optimizely and Episerver plugin documentation
    • User Interface Integrations
  7. Fotoware Mobile
    • User guide for Fotoware Mobile for iPhone and Android
    • User guide to FotoWeb for iPad (Legacy)
    • User guide to FotoWeb for iPhone and Android (Legacy)

Contact Us

If you still have questions or prefer to get help directly from an agent, please submit a request.
We’ll get back to you as soon as possible.

Please fill out the contact form below and we will reply as soon as possible.

  • Support

Table of Contents

Problem Cause Solution
  • Home
  • Fotoware On-Premises
  • Getting started
  • Licensing and product activation (On-Premises)

A Fotoware product asks for activation after an update to a newer version

What do you do if, after you update to a more recent version of our software, it asks for activation even though you have already activated a license key?

30. April 2025

Elaine Foley

Table of Contents

Problem Cause Solution

Problem

After you have downloaded and installed an updated version of your Fotoware software, the program will not start. It keeps asking for activation even though a license key has already been activated.

Cause

The most likely cause of this problem is that you have installed a newer version than your current license key allows you to run.

However, if you download a newer version than your license key allows, the program will keep asking for the activation key and refuse to start. Even though the key is valid, the program version will not run if it was released after your agreement has expired (the program performs a date check on the license against its own hard-coded version date).

Solution

Note: License keys expire 30 days after the agreement ends. All keys are backward compatible, so you can run an earlier build until the key expires. 

Customers with a valid agreement can find their latest license keys, which will allow them to run the latest version of the software, on the Fotoware Customer Portal.

Customers who don't have a valid agreement can contact Fotoware for assistance.

 
 
software activation update

Was this article helpful?

Yes
No
Give feedback about this article

Related Articles

  • Activating a Fotoware license with a license server
  • Activating FotoStation for Mac using the Terminal utility
  • Configuring Fotoware storage pools
eco-lighthouse-miljøfyrtårn

Company

  • About us
  • Resellers
  • Careers
  • Contact us

Help & support

  • Support center
  • Consultancy
  • Tech partners
  • Fotostation
  • System status

Trust Center

  • Legal
  • Security
  • Sustainability & ESG

Locations

Fotoware AS (HQ)
Tollbugata 35
0157 OSLO
Norway
FotoWare Switzerland AG
Industriestrasse 25
5033 Buchs (AG)
Switzerland

Copyright 2025 Fotoware All rights reserved.

  • Terms of service
  • Privacy policy
  • Cookie policy

Knowledge Base Software powered by Helpjuice

Expand